Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Position wird nicht angezeigt
#1
Hallo zusammen,

ich habe folgendes Problem.

Ich habe mir vor ein paar Tagen den CarPC installiert, und soweit funktioniert auch alles sehr gut.
Das einzige, womit ich noch Probleme habe, ist Navit.
Hier wird mir meine eigene Position leider nicht angezeigt.

Die passende Karte habe ich mir bereits besorgt und in das richtige Verzeichnis kopiert. Meinen Heimatort finde ich ohne Probleme, nur mein Standort wird mir leider nicht angezeigt.

Die GPS- Maus habe ich bereits am PC mit "Free GPS" getestet, hier scheint alles zu funktionieren.

Ich hoffe  mir kann jemand weiterhelfen.

Mein Setup:
Raspberry Pi 3
SkyTraq Venus8 USB GPS Maus
Pollin 7" Touchscreen
S-USV
Hifiberry DAC +
Zitieren
#2
Wie ist denn die Ausgabe von
Code:
cgps -s
im Terminal?
Zitieren
#3
Bei cgps -s wird mir folgendes angezeigt:


Code:
lqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqklqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqk
x    Time:       2006-06-28T12:03:15.000Z   xxPRN:   Elev:  Azim:  SNR:  Used: x
x    Latitude:   n/a                        xx                                 x
x    Longitude:  n/a                        xx                                 x
x    Altitude:   n/a                        xx                                 x
x    Speed:      n/a                        xx                                 x
x    Heading:    n/a                        xx                                 x
x    Climb:      n/a                        xx                                 x
x    Status:     NO FIX (99 secs)           xx                                 x
x    Longitude Err:   n/a                   xx                                 x
x    Latitude Err:    n/a                   xx                                 x
x    Altitude Err:    n/a                   xx                                 x
x    Course Err:      n/a                   xx                                 x
x    Speed Err:       n/a                   xx                                 x
x    Time offset:     369540430.460         xx                                 x
x    Grid Square:     n/a                   xx                                 x
mqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqjmqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqj
Zitieren
#4
Die GPS Maus wird nicht erkannt.

Vergewissere dich doch mal, dass in /etc/default/gpsd das Device richtig angegeben ist. Um den richtigen Eintrag zu ermitteln, ziehe zuerst einmal die Maus ab und gib dann im Terminal folgendes ein
Code:
tail -f /var/log/messages
Während das läuft, schließe die GPS-Maus an und achte auf die neu hinzugekommenen Einträge. Da sollte u.a. so etwas auftauchen:
Code:
Mar 14 20:17:50 raspberrypi kernel: [  219.655802] usb 1-1.2.4: cp210x converter now attached to ttyUSB0

Mit CTRL-C abbrechen und dann
Code:
sudo nano /etc/default/gpsd
und dort den Eintrag bei DEVICES kontrollieren und ggf. korrigieren
Code:
DEVICES="/dev/ttyUSB0"

Danach einen Neustart durchführen und noch einmal probieren.
Zitieren
#5
Erstmal vielen Danke für die Hilfe.

Hier die Befehle und die zugehörigen Codes.

tail -f /var/log/messages

Code:
Mar 14 20:33:59 raspberrypi kernel: [  123.366883] usb 1-1.5: cp210x converter now attached to ttyUSB0




sudo nano /etc/default/gpsd



Code:
# Default settings for the gpsd init script and the hotplug wrapper.

# Start the gpsd daemon automatically at boot time
START_DAEMON="true"

# Use USB hotplugging to add new USB devices automatically to the daemon
USBAUTO="true"

# Devices gpsd should collect to at boot time.
# They need to be read/writeable, either by user gpsd or the group dialout.
DEVICES="/dev/ttyUSB0"

# Other options you want to pass to gpsd
GPSD_OPTIONS="/dev/ttyUSB0"

das sind die Daten die bei mir ausgegeben werden. 
Leider dennoch keine Anzeige der eigenen Position in Navit.

Wenn es an der USB- Maus liegen würde, würde mich das auch sehr wundern.
Ich teste bereits die zweite.
Zitieren
#6
Das ist soweit alles richtig.

Da fällt mir jetzt nicht mehr viel ein. Außer: mach mal
Code:
sudo killall gpsd
sudo chmod a+r /dev/ttyUSB0

Danach Reboot und wieder testen.
Zitieren
#7
Auch das bringt leider keine Abhilfe.

ich habe gerade nochmal alles neu aufgespielt, auch jetzt funktioniert es nicht.

Noch irgend welche Ideen?

Oder muss ich in Navit selbst noch etwas veränder bzw. anpassen?
Zitieren
#8
Jetzt mal ne wirklich blöde Frage: Die GPS-Maus hat bei den Versuchen schon freie Sicht auf den Himmel? Und du wartest auch wirklich eine gewisse Zeit (auch mal ein paar Minuten), um dem Empfänger Zeit für einen Fix zu geben?
Zitieren
#9
Die freie Sicht auf den Himmel habe ich.

Mit Zeit für den Fix meinst du, dass ich einfach ein paar Minuten warten soll, oder dass ich nach dem Befehl cgps -s ein paar Minuten warten muss?
Zitieren
#10
Ja, der Fix kann unter Umständen schon mal ein bisschen dauern. Also nach dem Start einfach mal eine Weile abwarten.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt