Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
mein Projekt: Ersatz für Navi und Autoradio
#21
Ich bleibe erst mal bei Navit.
Bin gerade dabei, das nach meinen Bedürfnissen einzurichten, als nächstes versuche ich, die Sprachausgabe noch zu optimieren.

Eine RTC ist auch noch angekommen und wartet auf Installation.
Zitieren
#22
Bezüglich der Radioantenne kann ich nur sagen, dass Thema ist so kompliziert, da fehlen mir sowohl die Messgeräte als auch die Erfahrung, da geht es um Impedanzanpassung und Lambdawerte, um Kabelwiderstände etc. Da habe ich keine Ahnung von.
Also probiere ich aus, und was funktioniert, sprich, wo ich sauberen Empfang habe, wird genommen.
Neuere Autoantennen arbeiten mit 50Ohm (ISO-Stecker), alte Antennen mit 150Ohm (langer DIN-Stecker), meine Trennschaltung hat einen 75Ohm Widerstand drin, mit dem Widerstand arbeiten alle "normalen" Haus- und Zimmerantennen.
Es gibt Möglichkeiten, die Impedanz anzupassen etc.
Ist mir wie gesagt zu hoch das Thema.
Aber von 150Ohm Antenne auf 50Ohm Radioeingang soll laut Internet unkritisch sein.

Daher habe ich mal folgende Antenne bestellt: https://www.conrad.de/de/hirschmann-car-...74549.html
Dazu ein Verlängerungskabel und einen schraubbaren Antennenstecker. Und dann wird getestet, ob's geht oder nicht.
Zitieren
#23
So, statt Hardwarebastelei habe ich an Pfingsten mit der Software gekämpft.
Insbesondere die Sprachausgabe der Navit-Software und Bluetoothkopplung mit dem Handy sind eine Herausforderung.

Stand Sprachausgabe: Die Ausgabe mit eSpeak und pico2wave sind beide installiert und getestet. eSpeak klingt mehr wie "Roboter", pico2wave klingt natürlicher. Meine Wahl fiel letztendlich aus pico2wave.
Dazu habe ich SoX installiert, weil man damit die Sprachausgabe unglaublich anpassen kann. Es ist quasi alles möglich. Lautstärkeregelung, Bass und Höhen anpassen, Echo, Tremolo, Geschwindigkeit der Wiedergaben, komplette Verfremdung, unendliche Möglichkeiten.

Aber: die Sprachausgabe von Navit ist eine Mimose.
Nach einem kompletten Neustart nach Stromlos geht die Sprache. Bei Änderungen an der speech.sh ist es unbedingt nötig, nicht nur sudo reboot, sondern sudo shutdown. Beim Reboot funktionierte oft die Sprachausgabe NICHT, nur der "Gong" kam, aber keine Sprachausgabe. Warum? Keine Ahnung.
Was sich ebenfalls nicht gut vertrug bei mir: pulseaudio und die Sprachausgabe.
Deshalb die zweite Baustelle:

Bluetooth-Kopplung mit dem Handy.
Es geht. Zumindest theoretisch und halbwegs auch praktisch.
Aber ich hatte immer mit Problemen zu kämpfen.
Mal wurde der Raspberry 3b nicht als Medienwiedergabegerät erkannt nach dem Verbinden über Bluetooth.
Wenn dann die Verbindung als Mediengerät klappte, musste ich Wlan deaktivieren, sonst lief die Wiedergabe nur Sekunden.
Aber auch abgeschaltetes Wlan ist keine Garantie für dauerhafte stabile Wiedergabe. Auch mit deaktiviertem Wlan stockten die Lieder nach ein paar Minuten und liefen erst nach Druck auf Pause und Play am Handy weiter.
Keine praxisttaugliche Lösung.
Dazu kam, dass pulseaudio irgendwie mit der Sprachausgabe kollidierte, bzw. diese blockierte.
Alles dieses reichte, um die Handykopplung wieder zu deaktivieren.

Schade.

Ich friere den jetzigen Softwarestand ein und mache mal Backups. Die kommen dann in den Tresor. Ich habe jetzt so oft neu installiert, dass ich aus Schaden klug geworden bin. Demnächst wird nur noch die SD gewechselt, wenn ich mal wieder was verstellt habe.

An Hardware liegt noch eine RTC bereit, die auf Installation wartet.

Der Raspberry hat nun den ersten "Sonntagsausflug" im Auto absolviert und musste sich in der Praxis bewähren, was ganz gut geklappt hat, so dass ich jetzt an den Einbau ins Auto bzw. die Verlegung der Kabel denken kann.
Die Autoantenne fürs Radio kommt Ende des Monats.

Dann gehts weiter im Projekt.
Zitieren
#24
Ich finde es super dass du dein Projekt so mit uns teilst!
Zum Thema Bluetooth..... Da hat der Pi 3 schon immer Probleme. Damit das wirklich funktioniert musst du fast einen USB Bluetoothdongle arbeiten.
Zitieren
#25
Wenn das funktionieren würde, den internen Bluetooth deaktivieren und koppeln über USB-Bluetooth, dann würde ich das Thema noch mal versuchen...
Zitieren
#26
Zum abschalten vom internen Bluetooth probier mal folgendes.


Code:
sudo nano /boot/config.txt


Dann in der config.txt folgendes eintragen


Code:
dtoverlay=pi3-disable-bt


Evtl. musst du auch den Bluetooth Dienst abschießen...

Code:
sudo systemctl disable hciuart

Danach einfach neu starten....


P.S.
Wenn du auch das interne W-LAN abstellen willst musst du oben in der config.txt noch folgende Zeile hinzufügen

Code:
dtoverlay=pi3-disable-wifi


Das sollte es gewesen sein. Wink

Ich habe bei einem anderen Projekt eigentlich das gleiche Problem festgestellt. Mit externen Bluetooth funktiert es aber.
Zitieren
#27
Danke für den Tipp, wie ich den internen BT und WLan abschalte, dass hat sehr geholfen.

Ich habe nun internes BT auf meinem RasPi 3b abgeschaltet und einen USB-Bluetooth-Dongle installiert.
Mein Targus Bluetooth 4.0 Mini USB wurde erkannt und lief sofort.
Also Pulseaudio wieder aktiviert, Handy gekoppelt: voller Erfolg, keinen Verbindungsabbruch, kein Wiedergabe-Abbruch, und zwar trotz eingeschaltetem WLan.

Und jetzt das große ABER:
Wie vorher schon beschrieben auch hier wieder: wenn Pulseaudio aktiv ist, was für die Bluetooth-Audiowiedergabe nötig ist, gehen die gesprochenen Anweisungen vom Navit nicht mehr.
Ich hab's mehrfach getestet: Pulseaudio im Autostart (crontab...) = keine Sprachausgabe bei Navit.
Autostart von Pulseaudio in crontab auskommentiert = Sprachausgabe geht wieder.

Wie gesagt, mehrfach getestet. Es kommt kein Gong, keine gesprochene Anweisung.

Da die Navigation im Moment Priorität hat, verzichte ich wieder auf Bluetooth-Audio. Schade.

Wer auf die Sprachanweisungen verzichten kann, kommt mit einem USB-Bluetoothadapter bestens klar. Und vergesst am besten das interne BT vom RasPi 3b. Da wird niemand mit glücklich.
Zitieren
#28
So, nächste Etappe:
Eine RTC ist installiert.
Ich habe diese hier gekauft:
   

Schon fertig zum Aufstecken auf den GPIO, und so winzig, dass sie noch problemlos ins Gehäuse passte.
Die Software war dank der Anleitung von @Jack hier aus dem Forum schnell installiert. Danke dafür!

An den Bluetooth-Navisprachausgabeproblemen arbeite ich und denke, ich bin auf der richtigen Fährte.

Worauf ich noch scharf bin: einen OBD2 Adapter integrieren. Die paar Euro werde ich noch investieren!

So long!
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt