Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Touch bleibt weiß
#1
Hallo erstmal ans Forum,

ich habe gestern die Step by step anleitung durchgearbeitet jedoch stehe ich jetzt vor dem Problem das mein Bildschirm ( original 7" Raspi Touch-Screen) nach der Ladeanimation von Raspicar weiß bleibt.  
Es macht auch keinen unterschied wenn ich den TouchScreen abschließe und via HDMI verbinde und auf meinen Pc Bildschirm verbinde.

Vl. hat ja jemand einen Lösungsansatz. Achja... ich glaube ich habe mir die falsche GPS Maus gekauft? NAVILOCK GPS NL-602U USB

Beste Grüße

Andre
--------------------------------------------------
Raspberry Pi 3 B
7" Touch Screen
NAVILOCK GPS NL-602U USB
Zitieren
#2
In config.txt please add gpu_mem=256 , and check if you have this in same files :
dtparam=audio=on
hdmi_force_hotplug=1
max_usb_current=1
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 1024 600 60 6 0 0 0
hdmi_drive=1
Zitieren
#3
Hi,
das Problem mit dem White Screen hat sich erledigt. Habe alles neu aufgesetzt und bin wieder nach Anleitung vorgegangen, diesmal habe ich jedoch die raspi-config einstellungen nicht über meinen desktop (hdmi) gemacht sondern gleich schon den touch screen angeschlossen. 
Musste den Screen in den Einstellungen noch um 180° drehen und ab dann lief alles perfekt.

Wenn mir jetzt noch jemand sagen kann ob ich die gps maus nutzen kann dann wäre mein Tagessoll erreicht gg

Beste Grüße

Andre
Zitieren
#4
Die GPS Maus soll einen "Adopt SkyTraQ Venus8 Chipsatz" besitzen.
Ansonsten: Navit installieren und schauen, obs geht.
Reicht, wenn du die GPS-Maus Richtung Fenster hälst, ich habe sogar mitten im Raum genug Empfang...
Zitieren
#5
Die GPS-Maus sollte eigentlich funktionieren. Möglicherweise meldet sie sich aber unter einem anderen Device-Pfad an. Stecke sie mal ab und gebe im Terminal das hier ein:
Code:
tail -f /var/log/messages

Dann steckst du sie wieder ein und beobachtest die Ausgabe im Terminal. Da müsste dann etwas ähnliches erscheinen wie das:
Code:
Mar 14 20:33:59 raspberrypi kernel: [  123.366883] usb 1-1.5: cp210x converter now attached to ttyUSB0

Wichtig ist das "attached to ttyUSB0". Wahrscheinlich ist das bei dir eher "ttyACM0". Du kannst das dann im Terminal mit CTRL-C abbrechen.
Dann musst du nur noch die /etc/default/gpsd bearbeiten
Code:
sudo nano /etc/default/gpsd
und dort den ermittelten Device-Pfad ändern:
Code:
DEVICES="/dev/ttyACM0"

Danach Neustart und ausprobieren. Der erste Sat-Fix kann aber schon mal ein paar Minuten dauern. Also geduldig sein!
Zitieren
#6
Hi danke für die schnellen Antworten,
habe es jetzt mal so probiert wie von Jack beschrieben:

pi@raspberrypi:~ $ tail -f /var/log/messages
May 30 21:04:22 raspberrypi gpsd[548]: gpsd:ERROR: device open failed: No such file or directory - retrying read-only
May 30 21:04:22 raspberrypi gpsd[548]: gpsd:ERROR: read-only device open failed: No such file or directory
May 30 21:04:22 raspberrypi gpsd[548]: gpsd:ERROR: /dev/ttyUSB0: device activation failed.
May 30 21:04:25 raspberrypi gpsd[548]: gpsd:ERROR: device open failed: No such file or directory - retrying read-only
May 30 21:04:25 raspberrypi gpsd[548]: gpsd:ERROR: read-only device open failed: No such file or directory
May 30 21:04:25 raspberrypi gpsd[548]: gpsd:ERROR: /dev/ttyUSB0: device activation failed.
May 30 21:04:27 raspberrypi gpsd[548]: gpsd:ERROR: device open failed: No such file or directory - retrying read-only
May 30 21:04:27 raspberrypi gpsd[548]: gpsd:ERROR: read-only device open failed: No such file or directory
May 30 21:04:27 raspberrypi gpsd[548]: gpsd:ERROR: /dev/ttyUSB0: device activation failed.
May 30 21:04:28 raspberrypi kernel: [ 726.845251] usb 1-1.3: USB disconnect, device number 7

Wenn ich die GPS Maus anstecke kommt:

May 30 21:07:21 raspberrypi kernel: [ 899.935660] usb 1-1.4: new full-speed USB device number 8 using dwc_otg
May 30 21:07:21 raspberrypi rsyslogd-2007: action 'action 17' suspended, next retry is Wed May 30 21:08:21 2018 [try http://www.rsyslog.com/e/2007 ]
May 30 21:07:21 raspberrypi kernel: [ 900.068025] usb 1-1.4: New USB device found, idVendor=1546, idProduct=01a6
May 30 21:07:21 raspberrypi kernel: [ 900.068040] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
May 30 21:07:21 raspberrypi kernel: [ 900.068048] usb 1-1.4: Product: u-blox 6 - GPS Receiver
May 30 21:07:21 raspberrypi kernel: [ 900.068056] usb 1-1.4: Manufacturer: u-blox AG - www.u-blox.com
May 30 21:07:21 raspberrypi kernel: [ 900.069355] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device
May 30 21:07:21 raspberrypi gpsd[548]: gpsd:ERROR: device open failed: No such file or directory - retrying read-only
May 30 21:07:21 raspberrypi gpsd[548]: gpsd:ERROR: read-only device open failed: No such file or directory
May 30 21:07:21 raspberrypi gpsd[548]: gpsd:ERROR: /dev/ttyUSB0: device activation failed.
^C

War also genauso wie du es beschrieben hast. Danke dafür!!! Navi läuft jetzt und hat einen GPS fix!

Schönen Feiertag

Andre
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt