Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
UPS Pico funktioniert nicht
#1
Hallo,

habe ein Raspberry Pi 2 und wollte als Spannungsversorgung, nach dem das Auto aus ist, diesen UPS verwenden.
(https://www.rasppishop.de/Die-USV-UPS-Pi...rsorgung_1)

Bis jetzt habe ich alles zum laufen gebracht, nur diese Sache schaffe ich leider nicht alleine.

Hat schon jemand erfahrung mit dem UPS Pico? Bei mir schaltet sich alles sofort aus.
Zitieren
#2
Ich nutze die selber nicht, würde mir aber denken, dass die UPS Pico auch ohne irgendwelche Ansteuerung per Software Strom liefern sollte...Ist sie vielleicht nicht richtig geladen?
Raspberry Pi 2, HifiBerry, Jessie und Kodi 15.2
Zitieren
#3
Leider nicht.

Laut der Beschreibung im Internet, nutzt die UPS Pico den GPIO_GEN22.
Ich glaube das Radio-Modul nutzt den gleichen GPIO, habe aber keins angeschlossen.

Ist es möglich die Nutzung des Radios zu deaktivieren, damit der Pin frei für die USP ist?

Weiß leider nicht, wie ich mit dem Problem weiter komme und hoffe das mein Projekt daran nicht scheitert.
Zitieren
#4
Ich würde Dir raten, erstmal ein reines Raspbian zu nutzen, ohne irgendein Projekt drauf, und darauf zu probieren, ob Du die USV zum laufen bekommst.
Hast Du bei der Installation nach Anleitung gearbeitet? Speziell nach dieser hier: http://www.pimodules.com/_pdf/Simple_Set...S_PIco.pdf ?
Raspberry Pi 2, HifiBerry, Jessie und Kodi 15.2
Zitieren
#5
Bin wieder in Deutschland und habe mir die letzen Tage mal wieder etwas Zeit für das Profjekt genommen.

Auf einem frischen Raspbian-Image funktioniert es ohne Probleme.

Aber wenn ich es mit dem CarPcImage versuche startet Kodi nicht, erst wenn ich die UPS Pico wieder vom Raspberry abnehme.
Ich verstehe den Grund nicht. Aber es hängt vielleicht damit zusammen das das GPS-Modul die gleichen GPIOs verwendet wie die UPS.
Kann mir jemand dabei helfen? Huh

Vielen Dank!
Zitieren
#6
Radio nutzt GPIO25 bzw PIN22. Was nutzt die Pico denn nu? Und welches GPS Modul?
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#7
Die UPS nutzt die GPIO_GEN22 und GPIO_GEN27.

An das Radio habe ich noch garnicht gedacht.
Bin davon ausgegangen das ein GPS-Modul an den GPIOs angeschlossen wird.
Zitieren
#8
Nö GPS wird via USB angeschlossen und die Pico nutzt GPIO22 und RADIO GPIO25. Dürfte sich also nicht stören.
Da müsste man via Ausschlussverfahren arbeiten. Also mal suchen wo das Radio initialisiert wird und das einfach mal auskommentieren.

Glaub unter /opt/carpc/ liegen die StartCarPc_Stage1 und 2 wo sowas drin stehen könnte.
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#9
Hab in der StartCarPC_Stage2 die gpio_description auskommentiert. Leider ohne erfolg.

Wenn ich die UPS testen will bekomme ich diesen Fehler:

Code:
sudo python /home/pi/picofssd.py
/home/pi/picofssd.py:7: RuntimeWarning: This channel is already in use, continuing anyway.  Use GPIO.setwarnings(False) to disable warnings.
 GPIO.setup(27, GPIO.IN, pull_up_down=GPIO.PUD_UP) # Setup pin 27 as an input
/home/pi/picofssd.py:8: RuntimeWarning: This channel is already in use, continuing anyway.  Use GPIO.setwarnings(False) to disable warnings.
 GPIO.setup(22, GPIO.OUT) # Setup pin 22 as an output

Broadcast message from root@CarPi (pts/2) (Wed Feb  3 22:43:09 2016):

The system is going down for system halt NOW!

Vielleicht kann mir ja jetzt jemand helfen. Die Fehlermeldung habe ich selbst erst heute entdeckt.
Zitieren
#10
Gibt es denn gar keine Lösung für mein Problem?  Huh
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt