Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Hifiberry DAC+ light in CarPi einbinden
#1
Hallo an Alle!

Ich baue gerade ein altes Nordmende Radio um. Hinein kommt ein Pi2 mit einem Raspberry 7" Touch Display. Der Sound soll aus einem Hifiberry DAC+ light kommen (und das ist mein Problem). Ich benutze das CarPi Image von Christian (Vielen Dank dafür an dieser Stelle Smile ) mit Jessi und Kodi 15.2.
Ich habe den Hifiberry nach dieser Anleitung installiert. Laut aplay -l wird er auch erkannt:


Code:
pi@CarPi ~ $ aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: sndrpihifiberry [snd_rpi_hifiberry_dac], Gerät 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
 Sub-Geräte: 1/1
 Sub-Gerät #0: subdevice #0


Wenn ich reboote kann ich in den Einstellungen in CarPi dann als Audioausgabe zusätzlich zwei neue Punkte auswählen:

ALSA: Playback/recording through the PulseAudio sound (mehr wird nicht angezeigt)

und

ALSA: PulseAudio Sound Server

Bei beiden Optionen bootet CarPi nicht mehr und sagt:


Code:
kodi.bin: Sinks/AESinkPi.cpp:200: virtual bool CAESinkPi::Initialize(AEAudioFormat&, std::string&): Assertion `0' failed.


Jetzt weiss ich nicht mehr weiter. Habe es schon ein paarmal probiert, immer mit einem frischen Image.

Was ich nicht kapiere, ist diese PulseAudio Sache. Muss ich das irgendwie auch installieren? Auf der Hifiberry Seite steht davon nichts.

Meine raspi-blacklist.conf sieht so aus:

Code:
# blacklist spi and i2c by default (many users don't need them)

blacklist spi-bcm2708
#blacklist i2c-bcm2708
#blacklist snd-soc-pcm512x
#blacklist snd-soc-wm8804



Hier ist die /etc/modules:

Code:
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

#snd-bcm2835
i2c-dev
i2c-bcm2708


Und hier die /boot/config.txt:

Code:
# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=25
#overscan_right=25
#overscan_top=25
#overscan_bottom=25

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=4

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=1000

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

core_freq=500
sdram_freq=500
# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=1000

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

core_freq=500
sdram_freq=500
over_voltage=2
gpu_mem=256
dtparam=i2c_arm=on

#device_tree_param=i2c0=on,i2c1=on,spi=on

dtoverlay=hifiberry-dac

lcd_rotate=2


Ich habe auch hier im Forum diesen Beitrag gelesen, hat mir aber leider auch nicht weiter geholfen.

Hoffe mir kann jemand helfen, bin echt am verzweifeln. Alles ist schon fast fertig, ich habe von meinen Kollegen eine schöne Blende aus Plexiglas CNC-gefräst bekommen,
habe schon alle Teile die ich brauche, es hängt jetzt echt nur noch an der Software... Cry

Vielen Dank, Gruß Stefan
Zitieren
#2
teste doch mal osmc.tv
Zitieren
#3
Hi,

habe das Problem mit Hilfe eines Freundes gelöst.
Man muss einfach nur Pulse-Audio deinstallieren, dann kann man in den Systemeinstellungen den Hifiberry als Audioausgabe auswählen.


Code:
sudo apt-get remove pulseaudio
Zitieren
#4
(25.05.2016, 11:24)Schnubb schrieb: Hi,

habe das Problem mit Hilfe eines Freundes gelöst.
Man muss einfach nur Pulse-Audio deinstallieren, dann kann man in den Systemeinstellungen den Hifiberry als Audioausgabe auswählen.


Code:
sudo apt-get remove pulseaudio


Ich habe Andrejs Carpi system installiert und hatte ein sehr ähnliches Problem. Meine Lösung war in `/etc/modules` die Zeile bcm2708 auszukommentieren. (Hifiberry wurde über dtoverlays konfiguriert)
Zitieren
#5
Hallo,

Ich habe meinen Hifiberry DAC+ Pro per dtoverlays konfiguriert. Den Standard-Soundtreiber kommentiert man aus, dann läuft es.

Viele Grüße

Fred
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt