Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Navit bleibt still
#11
ja, müßte auch ohne sudo funktionieren.
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#12
So, endlich wieder am Gerät.
sudo espeak "Hello World" ertönt laut und deutlich Hello World aus dem Lautsprecher.

Mit alplay -r 44100 /home/pi/.navit/notification3.wav ertönt der Gong.

Scheint schon mal grundsätzlich zu gehen.
Warum nicht in Navit?
Zitieren
#13
Soweit bin ich auch.
Musste mich vorher mit der USB-Soundkarte rumärgern.... um die Karte als Default hinzukriegen.
Ich hatte jetzt angenommen, dass Navit spricht, konnte es aber noch nicht testen, da der Pi derzeit wieder auf dem Schreibtisch liegt.
Wenn es nicht funktioniert, müßte es an der Ausgabe der txt. Datei von Navit an espeak liegen?
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#14
Fehler gefunden:
In /home/pi/.navit/xml/announcements.XML

gibt es eine Zeile die mit <speech vocabulary_name= beginnt.
Dort stand hinter active= 0. Ich war mir sicher, dass schon mal geändert zu haben, war es aber nicht.
Nach Änderung auf active=1 und einem Neustart lief die Sprachausgabe!!!

Übrigens: die erste Sprachanweisung ertönt erst nach der ersten Bewegung des Fahrzeugs. Ein Test auf dem Küchentisch ist also zwecklos, es sei denn man hat eine lange Stromschnur und einen Tisch mit Rollen und Sat-Empfang in der Wohnung. Big Grin Angel

Die synthetische Stimme klingt wie eine Mischung aus deutsch-sprechendem Niederländer und Roboter. Aber gut verständlich.  Wink

Wichtg auch: in der genannten announcements.xml muss auch in der genannten Zeile $HOME durch /home/pi ersetzt werden.

In der Datei /home/pi/.navit/speech.sh habe ich zudem den Parameter beim Aufruf von espeak -v geändert von "en" in "de" 
Also -> sudo aplay -r 44100 /home/pi/.navit/notification3.WAV & sleep 0.7 && sudo espeak -vde+f4 -s150 -a 150 -p 50 "$1" --stdout | aplay
Zitieren
#15
frankie0815,

WOW! Das hilft mir sehr!
Ich habe weder "eine lange Stromschnur und einen Tisch mit Rollen", noch momentan einen GPS-Empfänger.
Denn der ist schon im Auto verbaut.
Für DAU's, wie mich:
<speech vocabulary_name="1" vocabulary_name_systematic="0" type="cmdline" data="/home/pi/.navit/speech.sh %s" cps="10" active="0"/>
<!-- <speech type="cmdline" data="flite -t '%s'"/> -->

Ist das so richtig?
<speech vocabulary_name="1"

weiterhin: data=" /home/pi/ ? (Leerschritt " / ?)
Diese Information würde mir einen Test-Umbau ersparen.

VG
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#16
Wird bis heute abend dauern, dann starte ich nochmal den CarPi und kopiere die Zeilen.
Bei active="0" ändern in active="1"
Der geänderte Pfad sieht richtig aus.
Wie gesagt, dauert ein bisschen. Bin Unterwegs.

*edit*
Die komplette Zeile in der announcements.xml lautet richtig:
Code:
<speech vocabulary_name="0" vocabulary_name_systematic="0" type="cmdline" data="/home/pi/.navit/speech.sh %s" cps="10" active="1"/>
Zitieren
#17
Sehr vielen Dank!
Dann werde ich morgen auch mal im Auto testen.

Hast Du auch mal in den "waze" Thread geschaut?
Installiert habe ich waze und es läuft. Nur kann ich es komischerweise nicht mit Putty über netzwerk starten, sondern nur über die Konsole von Jessie
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#18
Also:
notification3.wave kommt (für meinen Geschmack etwas zu laut)
Aber keine Sprachausgabe :-(
Die Voice-Datei de ist vorhanden.
Ist das Problem f4 - female voice 4?
Ich teste jetzt mal mit en

Meine vollständige speedch.sh lautet jetzt:

#!/bin/bash


# Bugfixed by hawkeyexp
#echo '$1' > /home/pi/out
# f4 - female voice 4
# -s speed
# -g delay between words
sudo aplay -r 44100 /home/pi/.navit/notification3.wav & sleep 0.7 && sudo espeak -ven+f4 -s150 -a 150 -p 50 "$1" --stdout | aplay

Meine vollständige announcements.xml:

<navigation>

<announce type="street_0,street_1_city" level0="25" level1="100" level2="200" unit="m"/>
<announce type="street_2_city,street_3_city,street_4_city,ramp" level0="50" level1="200" level2="500" unit="m"/>
<announce type="highway_city,street_1_land,street_2_land,street_3_land,street_4_land" level0="100" level1="400" level2="1000" unit="m"/>
<announce type="street_n_lanes,highway_land" level0="300" level1="1000" level2="2000" unit="m"/>
</navigation>

<!-- Navit provides speech output in text format.
If you have a speech synthesizer like festival lite installed, you can get turn by turn directions out of navit. Please set the "cps"-value to how many characters your tts engine approximately speaks per second.
The default is text output to the shell -->
<!--<speech type="cmdline" data="espeak '%s' -ven+f4 -p45 -s120 --stdout | aplay" cps="15"/>-->
<!--<speech enabled="yes" type="cmdline" data="espeak -ven+f4 '%s' | aplay-" cps="15"/>-->
<!--<speech type="cmdline" data="%s" cps="10" />-->
<speech vocabulary_name="0" vocabulary_name_systematic="0" type="cmdline" data="/home/pi/.navit/speech.sh %s" cps="10" active="1"/>
<!-- <speech type="cmdline" data="flite -t '%s'"/> -->
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#19
-ven+f4 english läuft auch nicht.
Momentan bin ich ratlos.....
espeak "Hello World" funktioniert, allerdings mit Fehlermeldungen:
pi@raspberrypi:~ $ espeak "hello World"
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2239: (snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pulse.c:243: (pulse_connect) PulseAudio: Unable to connect: Connection r                                 
efused

ALSA lib pulse.c:243: (pulse_connect) PulseAudio: Unable to connect: Connection r                                
efused

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
Zitieren
#20
Wenn nachher der Pi wieder läuft (SD-Karte zerschossen), Backup spielt gerade wieder zurück, poste ich die speech.sh.
Die XML sieht gut aus.
In der speech.sh die Zeile, die mit aplay beginnt, ist bei mir komplett anders.

Die "Fehlermeldungen" beim Abspielen in der Befehlszeile habe ich auch, funktionieren tuts trotzdem.

Etwas Geduld noch bitte.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste
RasPiCarProjekt