Themabewertung:
  • 1 Bewertung(en) - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Diskussionsthread - CarPi Step-by-Step Anleitung
#11
Getestet! Und zwar auf einem Pi2. Läuft nach kleinen Anlaufschwierigkeiten.
Die Installation lief ok. Nur wollte Kodi nicht starten. Fehlermeldung:
Code:

Last login: Sun Oct 23 00:34:47 2016
KODI is starting...
Could not init logging classes. Permission errors on ~/.kodi (/home/pi/.kodi/temp/)
ERROR: Unable to create application. Exiting

Abhilfe: temp-Verzeichnis erstellen und die richtigen Permissions für home/pi vergeben:
Code:
sudo mkdir /home/pi/.kodi/temp
sudo chmod -R a+rwx /home/pi

Danach soweit alles ok. Habe aber noch nicht alles getestet. Aber bis jetzt schaut's gut aus! Smile

Und noch eine Frage: das Kalibrierungs-Plugin ist nicht dabei oder hab' ich es nur nicht gefunden?

Ich sage jetzt einfach mal danke Christian für die ganze Arbeit! Dieses Tutorial erleichtert die Installation wirklich immens!
Zitieren
#12
Danke Jack fürs testen. Ich nehme das temp Verzeichnis noch mit auf.
Kalibrierungsplugin kann ich auch noch rein packen, aber das hat bei mir nie richtig funktioniert, deswegen hab ich es weggelassen.

Und was ich cool finde ist, dass das Bootvideo läuft ;-)
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#13
Hi Christian,

habs gestern Abend kurz angetestet.
Eine Sache die du auf jeden Fall noch fixen kannst: im install_carpc.sh, Zeile 58, da ist vor dem 'R' kein - sondern ein Gedankenstrich.
Ich muss in Kodi noch manuell den Skin ändern und irgendwie hat der noch nicht 100% gepasst bei mir, schau ich mir aber heute nochmal genauer an, woran das lag.
Gruß

Snirf
Zitieren
#14
Den Gedankenstrich sehe ich nicht. Bei mir ist das ein Bindestrich und verhält sich beim Installieren auch so.
Ich hab jetzt mal eine Grundkonfiguration von Kodi mit ins Paket gepackt. Sprache steht auf English, aber Skin auf Xtouch und dort auch Farben etc. schon vordefiniert.
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#15
Hallo Christian,

danke, dass du dir die Arbeit gemacht hast. Ich habe mir deine aktuelle Datei heruntergeladen und habe dazu ein paar Anmerkungen:

Dein Script installiert zuerst WiringPi von git und erst danach git. Das klappt nur, wenn git schon installiert ist. Ich habe die Zeile nach vorne kopiert.
Außerdem ist der Strich in
# Fix user rights
sudo chown –R pi:pi /home/pi
tatsächlich kein hyphen, sondern ein en dash, auch ich bekomme da einen Fehler. Das Archiv habe ich direkt auf dem Raspi entpackt und nicht geändert. Alle anderen Striche sind in Ordnung.

Ansonsten lief es reibungslos und sofort. Ich muss das Radio noch bauen und den piusv-daemon nachinstallieren (der ist rausgeflogen?), dann kann ich noch mal Bescheid sagen, wie es wirklich funktioniert.

Ach so: Man sollte nicht raspbian lite nutzen, sondern die Desktop-Version, wenn man nicht händisch die Fehler beheben möchte.
Zitieren
#16
Danke fürs testen und die Hinweise. Ich korrigiere das grade und lade ein neues Paket hoch.
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#17
Ach ja, was mir grad noch einfällt: magst du vllt einen symlink 'jessie_kodi15_current.zip' auf die jeweils aktuelle Version machen? Dann musst du zum einen nicht immer den ersten Post anpassen und wenn man selber testen weiß man so auch, dass man immer die aktuellste Version verwendet.
Und was ich vorhin ganz vergessen hab: auch von mir einen herzlichsten Dank für deine Mühe!!!
Zitieren
#18
Hallo Christian...

habe mir mal erlaubt dein Step by Step zu testen... ganz nach deiner Anleitung alles soweit versucht für einsteiger...
ich weiß ja nicht genau ob das alles für Anfänger gemacht sein soll oder doch schon ehr für fortgeschrittene...
aber ich beschreibe dir einfach mal meine punkte das du vllt selber da noch eins zwei kleine Verbesserungen anpassen kannst... 


15:38 Uhr
habe mir dazu eine clean SD Card genommen, 
dann von Raspian den stand 2016-09-23-rasbian-jessie zu installieren über Win32 Disk Imager
danach sudo apt... alles durchgeführt, was auch ok wahr soweit
boot punkt auch alles soweit gut eingestellt
unter Advanced hatte ich dann meine ersten kleinen Schwierigkeits punkte gehabt aber habe sie behoben bekommen...
in der boot/config.txt habe ich leider nicht das selbe zu stehen wie bei dir ( vllt etwas bei der Advance doch falsch gewesen )
Code:
# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
#dtparam=i2s=on
dtparam=spi=off
zur Installation des CarPi System
normale Eingabe Schwierigkeiten gehabt gegen über deinem Link... bei kompletter einfacher Eingabe...
Code:
pi@raspberrypi:~ $ wget https://download.christian-brauweiler.de/RaspberryPi/CarPC/2016-10-23_carpc_jessie_kodi15_rpi2-3.zip
--2016-05-27 12:03:20--  https://download.christian-brauweiler.de/RaspberryPi/CarPC/2016-10-23_carpc_jessie_kodi15_rpi2-3.zip
Auflösen des Hostnamen »download.christian-brauweiler.de (download.christian-brauweiler.de)«... fehlgeschlagen: Der Name oder der Dienst ist nicht bekannt.
wget: kann die Host-Adresse »download.christian-brauweiler.de« nicht auflösen

wenn man den Link rein kopiert über den PI geht es...  was leider nicht so toll ist wenn man über einem anderen pc sich die Anleitung durch liest...
dann ganz einfach die install durchgeführt...


20:10 Uhr
install zeit ca 4 stunden... weis ja nicht ob das normal ist aber ist ok bis hier her...

Code:
etc/init.d/asplashscreen
home/pi/.kodi/userdata/advancedsettings.xml
home/pi/.kodi/userdata/guisettings.xml
boot/cmdline.txt
chown: ungültiger Benutzer: „–R“
System almost ready! Check the manual for the last steps...
das ist als Fehler noch aufgetreten was ich auch gesehen habe das es bei anderen genauso wahr...

habe mal ein paar schnelle Test durchgeführt für den normalen Benutzer und es läuft alles soweit... Rest sind sonder Einstellungen...

fazit: eine wirklich gelungene Sache in allem... Hut ab auf jeden fall... Wink
CarPC / Raspberry Pi 3 / 7" Display im Audi A3 Halter
Zitieren
#19
Hallo,

schonmal gute Arbeit die du da geleistet hast.

Ich möchte dir hier die Probleme mitteilen die ich alle zu lösen hatte und die Schritte für meine spezifische Installation (vollständigkeitshalber) (RPI 3).
Bilder kann ich bei Bedarf nachreichen.

1. Einstellen des Touch-screens in kodi (kannst du nicht mit rein nehmen, ist klar, aber evtl. wäre ein verweis gut, wie es geht).
2. Aktivieren meiner USB soundkarte über die alsa.conf.
3. Das Boot Video bedeckt Auflösungsunabhängig immer in etwa das obere linke viertel des Displays.
4. Soll sofort nach den Boot (22sec) Navigiert werden, so bedeckt das Bootvideo die Navigation. Ein Bootlogo, dass beim start von Kodi verschwindet wäre evtl. eine bessere Option.
5. Touch in Navit (=Touch in Raspbian) funktioniert nicht richtig / muss erst konfiguriert werden.
6. Dank overscan deckte Navit nicht den ganzen Bildschirm ab.
7. "Zurück" Button in Navit zu Kodi ist bei mir 5x5mm groß und ganz in der ecke. Das ist eingebaut mit dem Finger nicht zu erreichen.
8. Nach dem Start wird in der Playzeile immer FM87.5 angezeigt. ich nutze jedoch kein Radiomodul und kann somit auch keine FM Sender empfangen. Eine "Last Played" (entweder Radio oder Musik/Video) wäre hier sinnvoller.

Viele Probleme hätte ich mit dem Orginalen Touchscreen wohl nicht. Dieses konnte ich aus Platzgründen jedoch nicht verwenden.
Das ist, was ich bisher alles entdeckt/gemacht habe. Vl. ist für dich ja das ein oder andere in der Anleitung Erwähnungswürdig.

Gruß, Kormi
Zitieren
#20
@Topsi:
Die config.txt soll abgeglichen werden. Falls dort nicht das steht was bei meiner Beschreibung steht, sollte es ergänzt/geändert werden. Ich hatte Probleme mit dem Radio Modul falls das nicht so da stand.
Der Download geht bei mir Problemlos über wget. Keine Ahnung was du da für Probleme hattest.
Es sollte keine 4 Stunden dauern. Bei mir war das nach ca. 30 Minuten auf dem Pi3 erledigt.

@Kormi:

1. Steht dabei das es auf meine Hardware abgestimmt ist und im Forum sind andere Touchscreen Configs angegeben.
2. Ist bei mir nicht Notwendig. USB rein und in Kodi umstellen, fertig.
3. Das hängt vermutlich mit deiner Auflösung zusammen. Wenn diese nicht 800x480 ist, dann passen die Parameter in der "asplashscreen" Datei unter /etc/inti.d/ nicht mehr.
4. Da könnte ich mal gucken dass das Video (omxplayer) gekillt wird wenn Kodi geladen wurde.
5. Das liegt wohl auch an deinem Touchscreen. Mit dem offiziellen Touchscreen geht das Problemlos. (siehe Punkt 1)
6. Nicht meine Baustelle. Ist wieder abhängig von deinem Screen.
7. Das habe ich so angepasst weil es bei 800x480 zu groß ist und andere Elemente in Navit überdeckt. Lad dir den Skin von snaga selbst runter und kopier es drüber.
8. Wieder nicht meine Baustelle. Wenn du von der Hardware abweichst weil du es nicht nutzt dann musst du das Radio deaktivieren.

Danke trotzdem, aber ich wollte nicht von 0 Anfangen. Die Informationen die hier bereits zu finden sind müssen ja nicht extra noch mal da reingeschrieben werden. Vielleicht verlinke ich es wie in den anderen a la FAQ.
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 9 Gast/Gäste
RasPiCarProjekt