Themabewertung:
  • 1 Bewertung(en) - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Diskussionsthread - CarPi Step-by-Step Anleitung
#21
Thumbs Up 
Ich habe die Schritt-für-Schritt Anleitung mal getestet und bin begeistert. Rolleyes
Habe mein RPI3 neu aufgesetzt mit dem neusten rasbian und bin deiner Anleitung gefolgt. Lief alles ohne Probleme durch und funktionierte im ersten Anlauf. Hat alles in allem keine Stunde gedauert. Big Grin Weiter so!
Zitieren
#22
Zop!
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#23
Hallo Christian

Als erstes danke ich dir 1000x für deine Arbeit. Hab meinen zweiten Carpi neu aufgesetzt gem. Anleitung hat allles top funktioniert.
Raspberry Pi 2 , Pollin 7" Display, PIco USV, Jessie Image
Am Testen Raspberry Pi 3, 7" Orginal Display, Jessie Image
Zitieren
#24
Hi Christian,

danke für das Update und die gute Anleitung.
Nichts desto trotz hab ich es mal wieder geschaft, es nicht zu schaffen.
Wie in der Anleitung gesagt hab ich einfach mal alles mit Enter bestätigt. Blöderweise endet der RPi3 nun nach wie vor in der Konstole und loggt sich als pi ein.

Es gab einen Hinweis bei der Installation bzgl. lightdm.conf, ob diese beibehalten soll oder die geänderte version. Durch drücken von Enter habe ich die installierte version beibehalten. Liegt es vielleicht daran?
Ich bekomme auch kein Boot-video zu sehen sondern den normalen consolen prompt.
Im tty7 ist Navit gestartet im Fenstermodus auf der Desktopoberfläche (allerdings ohne map? map1.bin ist vorhanden)

Hier mal der output von dmesg: http://paste.debian.net/890927

Edit:
Anscheinend war der Download von der Zip-Datei korrupt:

Code:
Archive:  2016-10-23_carpc_jessie_kodi15_rpi2-3.zip
  inflating: carpc.tar.gz
  error:  invalid compressed data to inflate
  inflating: install_carpc.sh


Habs noch einmal runtergeladen und konnte es problemlos entpacken. Werde nochmal einen versuch starten Smile

Edit2:
Perfekt!
Die Datei war wirklich korrupt. Kodi.bin hatte gerade mal 10mb.

Läuft wie geschmiert. Navit funktioniert ohne Probleme (wenn das introvideo dann weg ist Wink), meine USB-Soundkarte angestöpselt und die wurde ohne probleme erkannt und konnte verwendet werden.
Dass schreit förmlich nach einem testeinbau die Tage Smile

Danke nochmal für die schöne Anleitung und diesen Reibungslosen aufbau des installers.
Zitieren
#25
Gibt die Tage noch ein Update vom Installer. hawkeyexp hat den noch mal schön aufgemöbelt und funzt nun auch mit Jessie Lite.
Zudem werde ich das Bootvideo beenden wenn Kodi da ist.

/edit: sehe schon, das hat hawk auch schon erledigt Smile
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#26
(23.10.2016, 09:01)cbrauweiler schrieb: Und was ich cool finde ist, dass das Bootvideo läuft ;-)

Hallo Christian,
ist es möglich das Bootvideo in deinem fertigen Image auch zum laufen zu bekommen? Was genau hast du gemacht, dass es nun funktioniert.
Deine Step-by-Step Anleitung wollte ich erst in der Weihnachtszeit probieren. Bin nämlich froh, dass mein CarPi nun endlich (fast) perfekt läuft und ins Auto umziehen durfte.

An dieser Stelle nochmals ein großes Dankeschön an dich, hawkeyexp, Jack und alle nicht genannten für eure Arbeit! Ich weiß wie viel Zeit das ganze in Anspruch nehmen kann.
Zitieren
#27
Ja das sollte möglich sein. Ist eigentlich nur eine kleine Änderung.

Code:
sudo nano /etc/init.d/asplashscreen
Code:
#! /bin/sh
### BEGIN INIT INFO
# Provides:          asplashscreen
# Required-Start: $local_fs
# Required-Stop:
# Should-Start:
# Default-Start:     S
# Default-Stop:
# Short-Description: Show custom splashscreen
# Description:       Show custom splashscreen
### END INIT INFO

do_start () {

    omxplayer --win "0 0 800 480" /opt/carpc/startup/loading_video.mp4 &
        # uncomment the following line to show static boot picture and comment out the line above
        #/usr/bin/fbi -T 1 -noverbose -a /etc/splash.png
    exit 0
}

case "$1" in
  start|"")
    do_start
    ;;
  restart|reload|force-reload)
    echo "Error: argument '$1' not supported" >&2
    exit 3
    ;;
  stop)
    # No-op
    ;;
  status)
    exit 0
    ;;
  *)
    echo "Usage: asplashscreen [start|stop]" >&2
    exit 3
    ;;
esac

:

Die eigentliche Änderung ist:
Code:
# Required-Start: $local_fs
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#28
Danke Christian, ich werde das später gleich mal testen und gebe dann Rückmeldung.
Zitieren
#29
Leider hatte ich bisher noch keinen Erfolg.
Vielleicht liegt es daran, dass ich die Änderungen mit dem Handy gemacht habe. Also deinen Code kopiert und mit JuiceSSH die Datei erstellt und eingefügt. Vielleicht passt da die Formatierung/Codierung nicht. Testweise hatte ich es auch mal statt dem Video mit dem splash.png probiert, aber auch das wurde nicht angezeigt.
Werde es morgen nochmal in Ruhe testen.
Zitieren
#30
Buongiorno.
Sorry für mein Deutsch durch Google Übersetzer, aber Navit nicht funktioniert, empfängt keine Signale von dem Touchscreen und Tastatur, aufgrund eines Fehlers.[Bild: UkyVQ2f.jpg]


/etc/xdg/autostart/lxpolkit.desktop fixed - "NotShowIn=GNOME;KDE;LXDE" checkbox lxsession-edit unchecked
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste
RasPiCarProjekt