Themabewertung:
  • 1 Bewertung(en) - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
RTAndroid - Projekt der Technischen Hochschule Aachen
#1
Sehr interessantes Projekt der RWTH Aachen dessen weitere Entwicklung im Auge zu behalten sich sicherlich lohnt. 

Android 7.1 läuft damit nativ auf dem RPI3 und man kann die Gapps inkl. des Google Play installieren und es läuft für meine Begriffe sehr flüssig.
Auch die Tochscreen-Funktion des originalen Displays lässt sich ohne große Problem aktivieren. 

Ich teste gerade im Auto Kodi 17.1 inkl. USB-Soundkarte und muss sagen es läuft bereits sehr gut. Auch meinen DVB-T - Stick mit RTL2832U Chip konnte ich mittels diverser Apps bereits als FM-RDS und DAB+ Empfänger nutzen. 

Hier mal der Link zur Projektseite: https://rtandroid.embedded.rwth-aachen.de/

Falls Interesse daran besteht kann ich auch gerne einen ausführliche Anleitung dazu erstellen.
Zitieren
#2
Android auf RPI3 klingt Interessant
Zitieren
#3
Hi leviathan
Ich hätte Interesse an einer Anleitung um das ganze mal zu testen, was mich noch wunder nimmt wie sieht es mit der Navigation aus? funktioniert dies mit dem Empfänger und einer APP?

Gruss Skorpionbird
Raspberry Pi 2 , Pollin 7" Display, PIco USV, Jessie Image
Am Testen Raspberry Pi 3, 7" Orginal Display, Jessie Image
Zitieren
#4
Moin,

auch ich wär an einer Anleitung heftig interessiert.

Gruß Wiki
Zitieren
#5
Also GPS und Navigation konnte ich leider noch nicht testen. Da werde ich mich wohl am WE mal dranmachen.

Hier gibt es eine sehr gute Anleitung, so bin ich auch vorgegangen: https://groups.google.com/forum/#!topic/...-6MyQKSf-M Falls die Anleitung nicht sofort angezeigt wird, ist der erste Beitrag von einem gewissen "Colton Griswold" 

Und hier die Änderungen für die boot.txt und die build.prop damit der Touchscreen funktioniert. Alles was mit einem "-" davor ist wird gelöscht, und alles mit einem "+" wird ergänzt:
https://raw.githubusercontent.com/RTAndr...ouchscreen

Viel Spaß damit!
Zitieren
#6
(04.04.2017, 15:59)leviathan schrieb: Also GPS und Navigation konnte ich leider noch nicht testen. Da werde ich mich wohl am WE mal dranmachen.

Hier gibt es eine sehr gute Anleitung, so bin ich auch vorgegangen: https://groups.google.com/forum/#!topic/...-6MyQKSf-M Falls die Anleitung nicht sofort angezeigt wird, ist der erste Beitrag von einem gewissen "Colton Griswold" 

Und hier die Änderungen für die boot.txt und die build.prop damit der Touchscreen funktioniert. Alles was mit einem "-" davor ist wird gelöscht, und alles mit einem "+" wird ergänzt:
https://raw.githubusercontent.com/RTAndr...ouchscreen

Viel Spaß damit!

Hallo kriege das mit dem Touchscreen einfach nicht hin. Kann mir bitte jemand genauere Instruktich geben bzw mir vllt seine Config Datei hier rein kopieren? Ich bekomme es einfach nicht hin. Habe das Original RPI 7" Display
Dankesehr schonmal
Zitieren
#7
Zitat:Hallo kriege das mit dem Touchscreen einfach nicht hin. Kann mir bitte jemand genauere Instruktich geben bzw mir vllt seine Config Datei hier rein kopieren? Ich bekomme es einfach nicht hin. Habe das Original RPI 7" Display

Dankesehr schonmal

Nutzt du Windows oder Linux? 

Wenn du Windows nutzt, solltest du dir zuerst einmal per VirtualBox z.Bsp. Ubuntu einrichten. Es müssen nämlich wie bereits geschrieben nach der Installation die Datei /config.txt wie auch die Datei /build.prop angepasst werden. Auf die Datei /config.txt hast du auch noch Zugriff unter Windows, da diese unter der Fat32 Partition im Ordner /boot liegt. Die /build.prop hingegen liegt auf einer Partition auf die du unter Windwos nicht ohne Weiteres zugreifen kannst. 

Wenn du Zugriff auf beide Dateien bekommst, und diese dann auch ändern kannst, sollten beide wie folgt aussehen: 

config.txt

Zitat:hdmi_force_hotplug=1
hdmi_drive=2
hdmi_group=2
hdmi_mode=87
hdmi_cvt=800 480 60 6 0 0 0
kernel=zImage
dtparam=audio=on
dtparam=i2c1=on
dtparam=i2c_arm=on
dtoverlay=vc4-kms-v3d,cma-256
dtoverlay=i2c-rtc,ds3231
dtoverlay=rpi-backlight
dtoverlay=rpi-ft5406
initramfs ramdisk.img 0x01f00000
mask_gpu_interrupt0=0x400
avoid_warnings=2


in der build.prop musst du nur an diesen Eintrag löschen, ansonsten funktioniert der Touchscreen unter RTAndroid nicht. Bzw. du hast kein Bild. 

Zitat:debug.drm.mode.force=1280x720
Zitieren
#8
Konnte schon jemand einen dab oder gps Stick ausprobieren?

Gruss
Zitieren
#9
Moin,
hab jetzt mal RTAndroid auf dem Pi installiert.

Abweichend von den vorher geposteten Links hab ich von der RWTAachen die letzte Version aus 2017 genommen, da der Link für das Download anscheinend nicht mehr funktioniert. wget meldete 404-Page not found.

Absolut wichtig ist es für diejenigen, die das Pi-Display nutzen, nach Schreiben der SD die zweite Partition wieder zu mounten und - wie schon gepostet - und die datei /build.prop zu bearbeiten. Die Zeile
Code:
debug.drm.mode.force=1280x720
muss zwingend raus, sonst ists mehr oder weniger dunkel. Auch die von leviathan geposteten Änderungen der config.txt sind absolute Voraussetzung.

Von den Änderungen der gapps.sh hab ich abgesehen, da ich eine andere Version genommen hab. Richtig nach Anleitung ausgeführt ist dann aber der Playstore installiert.

Die GpS-Maus funktioniert. Google Maps bleibt allerdings kurz nach Start (und richtiger Anzeige des derzeitigen Standortes) einfach stehen. Weiss der Geier, warum, die Map wird für den aktuellen Standort auf jeden Fall geladen.

Diverse von mir genutzte Apps (zB Atech Clock) lassen sich zwar installieren, geben aber keine Anzeige.

In Summe:
Tolles Projekt, im derzeitigen Stand aber als Ersatz für CarPi keine Konkurrenz.

Gruß Wiki
Zitieren
#10
Hallo Zusammen,

Ich habe jetzt auch den RTAndroid konfiguriert, und der Screen läuft ebenfalls (sehe seit ca. 20 minuten das Android Logo ist das normal?
Oder geht das schon viel zu lange so?

So hab es jetzt über 1h laufen lassen und ich sehe nichts weiteres als das startlogo
Hab das ganze auch schon neu formatiert ect.
(Dateien Angepasst 1. config.txt von hier kopiert und 2. in build.blob die Zeile debug.drm.mode.force=1280x720 gelöscht.)

Habe ich etwas vergessen?

1. wenn ich nur config.txt anpasse Startet Android jedoch stimmt der Screen size für das Original Rpi display nicht.
2. Anschlissend ändere ich die Build.blob und dann bleibt es hängen.


Gruss Schnibli

Edit:

Habe Das problem gefunden. mein Linux hat irgendwas mit der build datei angestellt. nun Funktioniert es.

Hab auch die gapps installiert, jedoch wird der Bildschirm Schwarz wenn ich Google Play Store öffnen möchte.

Edit:

Ebenfalls erledigt, Zuerst Google Account anmelden, dann Play Stor Starten.

Kann ich dich fragen wie du das gps zum laufen gekriegt hast?
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste
RasPiCarProjekt