Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi/CarPi startet nicht, sehe nur die Console/Terminal
#1
Hallo Leute,

ich habe eine RP 2 B+ und hab nach folgender Anleitung mein CarPi mit Jessi Lite installiert (2mal).
Ich nutze eine BT Tastatur und habe den Pi an einem HDMI Monitor. Die Konfiguration zu Navit/GPS Maus etc. habe ich erstmal übersprungen.

Folgendes habe ich "erfolgreich" gemacht:
Code:
cd /home/pi/carpc
./carpc-install.sh
sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo apt-get install libmysqlclient18 libmysqlclient-dev
sudo reboot
https://raspberry-blog.de/carpi-installa...ndsystems/

Leider erscheint nach dem schönen "CarPi" Ladebildschirm nur wieder die Konsole mit dem letzten Eintrag "Kodi starting.."

Kann mir jemand helfen? Smile  

Bin leider mit Linux etc. nicht sehr bewander und es ist mein erstes Raspberry Projekt.

Gruß
Tom
Zitieren
#2
Klar! weil bei der beschriebenen Intstallation in die Konsole gebootet wird.
Ausserdem ist die Beschreibung komplett veraltet und auch die Version vom Carpi selbst.

Probiere es mal hiermit.
https://raspicarprojekt.de/showthread.php?tid=1014

Kleine Anmerkungen von mir zur Version 2017:
- Nimm die Raspbian Jessie Full. Bei Lite kam es hin und wieder zu Problemen bei mir. Full benötigt aber etwas länger beim starten
- Nach Installation von Raspbian

Code:
sudo raspi-config

ausführen und folgende Einstellungen vornehmen
    - Dateisystem erweitern
    - Passwort von Rasperry auf beliebig ändern (In meinen Augen absolut wichtig)
    - Tastatur einstellen
    - Memory-Split auf 256 einstellen
    - Wenn SSH WLAN erwünscht einstellen

Danach weiter, wie in meinen Link beschrieben....

Da hast auch dann auch mehr Funktionen mit dem Carpi. Wink

Achja .... je nach verwendeten Display musst du die config.txt Datei anpassen.
Zitieren
#3
Ergänzend zur von Peziman geschilderten Vorgehensweise sei noch erwähnt, dass es mit neueren Raspbian-Versionen zu Problemen mit dem CarPi kommen kann. Deshalb am besten Raspbian Jessie vom April 2017 als Basis verwenden. Download hier.
Zitieren
#4
Vielen vielen Dank (-: für eure Hilfe.


Leider bekomme ich ein recht ähnliches Bild. Und habe bemerkt das ich zuvor ja auch schon Jessie 2017 hatte. Allerdings lite.

Huh


Angehängte Dateien Thumbnail(s)
   
Zitieren
#5
Probiere doch nochmal eine frische Installation unter Berücksichtigung folgender Punkte:

1. Raspbian-Image nochmal neu auf die Karte flashen
2. Pi booten
3. Im Terminal das Update von Bootloader und Kernel blocken:
Code:
sudo apt-mark hold raspberrypi-kernel raspberrypi-bootloader
4. Danach die Installation wie im Step-by-Step-Guide beschrieben durchführen.

Hintergrund ist der dass während der Installation gewisse Updates durchgeführt werden, die wiederum Probleme bereiten können. Mit dem obigen Befehl werden Kernel und Bootloader vom Update ausgenommen.
Zitieren
#6
Sorry dass ich diesen alten Thread nochmal ausgrabe aber der TE hat sich ja nie zurückgemeldet. Ich habe das gleiche Problem wie er. Ich habe mir extra einen Pi 3 geliehen und dort Raspbian Jessie (Rasbian Jessie Archiv) geflasht. Dann habe ich, wie Jack geschrieben hat, mit dem Befehl den Kernel und den Bootloader eingefroren und direkt danach das Installationsskript ausgeführt. Das dauert immer ein bisschen und danach reboote ich wenn es fertig ist. Dann kommt das schöne Intro und läuft auch ohne Probleme durch. Aber am Ende kommt von KODI eine fehlermeldung im Terminal, dass es eine Library nicht findet. Es scheint als würde er, obwohl Kernel und Bootloader eingefroren sind, trotzdem etwas kaputtupdaten. Muss er überhaupt etwas aus dem Internet nachladen? Falls nicht könnte man im Skript ja den Check für die Internetverbindung auskommentieren und den Pi offline schalten damit er nichts updaten kann.

LG
Zitieren
#7
Jetzt habe ich mal im install.sh apt update, upgrade und dist-upgrade auskommentiert. Aber er braucht noch immer eine Library. libmysqlclient.so.18

Ich habe die auskommentierten Sachen wieder eingebunden und das Skript nochmal ausgeführt. Jetzt scheint das zu funktionieren. Ich kann nicht sagen woran es liegt. Muss man nach dem einfrieren des Kernels und Bootloaders erst neustarten?
Zitieren
#8
(09.01.2021, 15:49)julijan1994 schrieb: Muss man nach dem einfrieren des Kernels und Bootloaders erst neustarten?
Nein, das ist eigentlich nicht nötig. Woran das Problem nun lag ist schwer zu sagen. Aber schön wenn es behoben ist und dein CarPC läuft! Und ein gut gemeinter Rat: mache bei Zeiten ein Backup von der Karte! Dann musst du nicht wieder bei Null starten, wenn beim weiteren Einrichten, Ausprobieren, etc. ... etwas schief geht. Wink
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 3 Gast/Gäste
RasPiCarProjekt