Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
RPi-Kameramodul als Dashcam 1.1.2 und Rearcam!
#61
@Gangwi16
Ich habe dieses Addon nicht in Verwendung, aber normalerweise sollte die Musik bei Verwendung weiterlaufen. Kanns nicht mit Sicherheit sagen, aber es würde mich schon wundern, wenn es anders wäre.

Wenn du den xTouch-Skin verwendest, kannst du das Hauptmenü beliebig konfigurieren. Nimm einfach einen Magic-Button mit der Action:
Code:
RunPlugin(plugin://id.des.addons)
Die ID müsste hier plugin.program.pidash lauten wenn ich mich nicht irre. Die korrekte ID findest du heraus, indem du die addon.xml des Addons öffnest. Die ID steht ganz am Anfang der xml. Oder du nimmst dafür einen Submenübutton her. Da ist in der neuesten Version des Skins bereits ein vorkonfigurierter Submenübutton für dieses Addon auswählbar.
Zitieren
#62
Hat geklappt danke dir...
Zitieren
#63
Liebe Community,

ist es wirklich so, dass dieses Plugin wie weiter oben erwähnt - nicht mit der Lite Version läuft und wenn ja, läßt sich das irgendwie lösen? Ich habe testhalber mal eine Pi Cam, die bei mir als Überwachungskamera läuft an den CarPi angeschlossen und (obwohl ich es im Raspi-config aktiviert habe) läuft die Cam nicht. Es geht auch nicht die rote Betriebs LED an. Ich habs auch an einem anderen Raspberry mit einer anderen SD (leider auch auf Lite basierend) mit anderem (kurzen) Flachkabel probiert mit demselben Ergebnis. Es liegt also definitiv nicht am Raspi, nicht am Kabel und nicht an der Kamera....  

Danke und lg
Marvin
Zitieren
#64
Hallo Gangwi16,

ich habe mal vor längerem diesen Blog gefunden.

"A Raspberry Pi dashcam with two cameras and a GPS"

Scheint an sich gut zu funktionieren; nur weiss ich nicht wie man das mit Kodi integrieren könnte.
Zitieren
#65
Hallo,

ist etwas geplant, das addon per Rückfahrsignal zu schalten?
Z.B. 12V vom Rückfahrscheinwerfer entsprechend zum Umschalten anpassen?

VG
B.C.
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#66
(20.07.2017, 09:56)auchentoshan schrieb: Liebe Community,

ist es wirklich so, dass dieses Plugin wie weiter oben erwähnt - nicht mit der Lite Version läuft und wenn ja, läßt sich das irgendwie lösen? Ich habe testhalber mal eine Pi Cam, die bei mir als Überwachungskamera läuft an den CarPi angeschlossen und (obwohl ich es im Raspi-config aktiviert habe) läuft die Cam nicht. Es geht auch nicht die rote Betriebs LED an. Ich habs auch an einem anderen Raspberry mit einer anderen SD (leider auch auf Lite basierend) mit anderem (kurzen) Flachkabel probiert mit demselben Ergebnis. Es liegt also definitiv nicht am Raspi, nicht am Kabel und nicht an der Kamera....  

Danke und lg
Marvin

Ich habe scheinbar auch obiges Problem. Eine Lösung gibt es dazu nicht?
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#67
Also... ganz so ist es nicht...die Cam funktioniert mit Jessie lite:

~ $ vcgencmd get_camera
supported=1 detected=1

raspistill -o image.jpg
Overlay funktioniert und image.jpg wird erstellt

Das Pi-Dashcam addon funktioniert nur nicht. Habe aktuell die Vers. 1.1.4 und dann die 1.1.2 getestet.

habe mal die service.py mauell gestartet und erhalte folgende Fehlermeldung:

import xbmc 
import error: No module named xbmc

Bei dem XBMC CarPC Manager unter "Addons - Aktive Addons" erhalte ich ein Icon, auf dem diagonal in rot steht "Version check"

Was läuft da falsch?



VG
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#68
Schau mal ins Kodi Log (/home/pi/.kodi/temp/kodi.log). Vielleicht lässt sich da etwas rauslesen.

Achja, das mit Icon vom "XBMC CarPC Manager" ist normal. Der Autor hat das Logo halt so designt. Das hat auch mit dem Dashcam-Addon nichts zu tun.
Zitieren
#69
Danke!
In der Kodi.log sind einige Errors - jedoch sehe ich nichts, was auf das "plugin.program.pidash" hindeutet.
Es gibt aber einen Error zum Skript "carDiagnostic", welches ich nicht benutze. Auch dieses Addon hat eine "service.py":
 ERROR: ExecuteAsync - Not executing non-existing script /home/pi/.kodi/addons/script.carDiagnostic/service.py
Evtl. gibt es dort ein Konflikt?

Soll ich die log mal hochladen?
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#70
Ich habe jetzt nochmal ein frisches image von Christian Brauweiler installiert, Da ist Rpi-Camera Dashcam 1.1.4 drauf.
Funktioniert auch nicht bei mir.
Die Funktions-Button für z.B. für Aufnahme sind ohne Funktion und ich sehe nur den blauen Hintergrund.
Die Camera selbst funktioniert. Getestet mit raspistill -o image.jpg
Ich weiß nicht mehr weiter....  :-(
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 6 Gast/Gäste
RasPiCarProjekt