Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Pollin 7T - Anschluss Touch-Controller
#1
Hallo allerseits,

ich habe mich das halbe Wochenende mit dem Touch des LS-7T herumgeschlagen und komme nicht klar. Inzwischen gehe ich nicht mehr von meiner eigenen Doofheit sondern von einem Hardwarefehler aus. Vielleicht fällt aber ja jemand noch etwas dazu ein.

Symptome:
* Controller LED blinkt bei Berührung des Screens
* Touch lässt sich nicht kalibrieren. Soweit ich es einschätzen kann werden nur die X-Werte an den Rechner übergeben
* lsusb: Controller ist da
* /etc/input/* erscheinen wenn der Controller eingesteckt wird, cat /etc/input* | od -x liefert Werte
* 1024x600 ist in der /boot/config eingetragen (mehrfach wiederholt, verschiedene Varianten getestet)
* /home/pi/touchscreen_axes_calib umbenannt (oder im normalen Raspian /etc/X11/xorg.conf.d/99-bla erstellt)

Inzwischen habe ich das Verbindungskabel zum Controller im Verdacht. In der Anleitung steht:

"... sodass die vier Einkerbungen und die Pins des Flachbandkabels nach unten zeigen ..."

So zusammengesteckt tut sich gar nichts (kein Blinen der LED bei Touch etc.).
Anders herum (wie auf diesem Foto) kommen die oben beschriebenen Symptome.

Irgendwer eine Idee? Sind flasch verlötete Kabel ein bekanntes Problem?

Liebe Grüße, Heiner
Zitieren
#2
Hallo Heiner

Versuch mal das USB Kabel am Controllerboard um 180 Grad gedreht anzuschliessen, hatte dies Problem auch und wurde auch im Forum schon diskutiert.



Gruss Mark


Angehängte Dateien Thumbnail(s)
   
Raspberry Pi 2 , Pollin 7" Display, PIco USV, Jessie Image
Am Testen Raspberry Pi 3, 7" Orginal Display, Jessie Image
Zitieren
#3
Oha, sicher das USB-Kabel?
USB liefert ja u.a. 5V.
Trau mich nicht so richtig ...
Zitieren
#4
Ich bin mir relativ sicher, dass Skorpionbird nicht das USB-Kabel meint sondern das Kabel zum Display auf der anderen Seite des Controller-Boards! Zumindest wenn man das verlinkte Bild betrachtet.

Wenn ich mich recht entsinne hat dieser schwarze Anschlussstecker bzw. die Buchse Einkerbungen, die das Einstecken nur in einer Richtung erlauben (es sei denn man wendet Gewalt an). Man muss nur Stecker und Buchse genau anschauen, dann sieht man schon welche Richtung richtig und welche falsch ist. Das "Umdrehen" kann also nur dann Sinn machen, wenn man es beim ersten Mal falsch gemacht hat. Wink Schließlich lässt sich die Anschlussrichtung am anderen Ende des Steckers wesentlich leichter ändern. Da würde ich dann unbedingt darauf achten, dass das Kabel so tief wie es geht eingesteckt wird und die Kontakte vorher auf Sauberkeit kontrolliert werden.
Zitieren
#5
Ah, sorry, ich hatte das Foto übersehen (ich muss mich erst mal an dieses Forum gewöhnen; hielt das Foto wohl für eine Signatur ;-)

Soweit ich mich erinnere hatte ich diesen Stecker auch schon einmal gedreht. Aber ich werde dem nachher noch mal genauer nachgehen. Dass der Touchscreen bei mir mit umgedrehtem Flachbandkabel "etwas" funktioniert deutet ja schon darauf hin, dass da irgendwo der Hase im Pfeffer liegt.

Danke euch beiden, liebe Grüße!
Zitieren
#6
(11.07.2016, 15:44)otterstedt schrieb: Ah, sorry, ich hatte das Foto übersehen (ich muss mich erst mal an dieses Forum gewöhnen; hielt das Foto wohl für eine Signatur ;-)

Soweit ich mich erinnere hatte ich diesen Stecker auch schon einmal gedreht. Aber ich werde dem nachher noch mal genauer nachgehen. Dass der Touchscreen bei mir mit umgedrehtem Flachbandkabel "etwas" funktioniert deutet ja schon darauf hin, dass da irgendwo der Hase im Pfeffer liegt.

Danke euch beiden, liebe Grüße!

Hi natürlich meinte ich nicht das USB Kabel :Smile Bei mir war es aufjedenfall so nach dem drehen ging es.
Raspberry Pi 2 , Pollin 7" Display, PIco USV, Jessie Image
Am Testen Raspberry Pi 3, 7" Orginal Display, Jessie Image
Zitieren
#7
Das Flachbandkabel steckt jetzt richtig herum drin, dafür ist der Stecker am Controller umgedreht.
Leider keine sichtbare Veränderung.

Ich habe jetzt mal evtest installiert und nachgesehen, was beim Raspberry ankommt wenn man einmal von links oben nach rechts unten über den Bildschirm streicht. Das Ergebnis muss ich wohl nicht komplett einfügen aber es passiert das Folgende:


root@T4:~# evtest /dev/input/event1
Input driver version is 1.0.1
Input device ID: bus 0x3 vendor 0xeef product 0x1 version 0x112
Input device name: "eGalax Inc. Touch"
Supported events:
 Event type 0 (EV_SYN)
 Event type 1 (EV_KEY)
   Event code 320 (BTN_TOOL_PEN)
   Event code 330 (BTN_TOUCH)
 Event type 3 (EV_ABS)
   Event code 0 (ABS_X)
     Value   2045
     Min        0
     Max     2047
   Event code 1 (ABS_Y)
     Value   1823
     Min        0
     Max     2047
 Event type 4 (EV_MSC)
   Event code 4 (MSC_SCAN)
Properties:
Testing ... (interrupt to exit)
Event: time 1468256533.292808, type 4 (EV_MSC), code 4 (MSC_SCAN), value d0042
Event: time 1468256533.292808, type 1 (EV_KEY), code 330 (BTN_TOUCH), value 1
Event: time 1468256533.292808, type 3 (EV_ABS), code 0 (ABS_X), value 2046
Event: time 1468256533.292808, type 3 (EV_ABS), code 1 (ABS_Y), value 88
Event: time 1468256533.292808, -------------- EV_SYN ------------
Event: time 1468256533.428800, type 3 (EV_ABS), code 1 (ABS_Y), value 87
Event: time 1468256533.428800, -------------- EV_SYN ------------
Event: time 1468256533.476808, type 3 (EV_ABS), code 1 (ABS_Y), value 88
Event: time 1468256533.476808, -------------- EV_SYN ------------
Event: time 1468256533.500822, type 3 (EV_ABS), code 1 (ABS_Y), value 94
Event: time 1468256533.500822, -------------- EV_SYN ------------
Event: time 1468256533.508827, type 3 (EV_ABS), code 1 (ABS_Y), value 106
Event: time 1468256533.508827, -------------- EV_SYN ------------
Event: time 1468256533.516828, type 3 (EV_ABS), code 1 (ABS_Y), value 125
Event: time 1468256533.516828, -------------- EV_SYN ------------

[ --- schnipp ---]

Event: time 1468256534.068903, type 3 (EV_ABS), code 1 (ABS_Y), value 1866
Event: time 1468256534.068903, -------------- EV_SYN ------------
Event: time 1468256534.076907, type 3 (EV_ABS), code 1 (ABS_Y), value 1885
Event: time 1468256534.076907, -------------- EV_SYN ------------
Event: time 1468256534.084906, type 3 (EV_ABS), code 1 (ABS_Y), value 1903
Event: time 1468256534.084906, -------------- EV_SYN ------------
Event: time 1468256534.092907, type 3 (EV_ABS), code 1 (ABS_Y), value 1920
Event: time 1468256534.092907, -------------- EV_SYN ------------
Event: time 1468256534.100907, type 4 (EV_MSC), code 4 (MSC_SCAN), value d0042
Event: time 1468256534.100907, type 1 (EV_KEY), code 330 (BTN_TOUCH), value 0
Event: time 1468256534.100907, -------------- EV_SYN ------------

Es kommen massenweise Y-Koordinaten aber keinerlei X-Koordinaten.
Tja, was schließe ich daraus?
Touchscreen kaputt?
Kabel kaputt?
Controller kaputt?
Keine Ahnung ...

Liebe Grüße, Heiner
Zitieren
#8
Schick das Ding zurück. Das drehen des Kabels bewirkt nur das X und Y Achse getauscht werden. Wenn da auf einer Achse nix ankommt ist wohl was matsch.
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#9
Jo, werde ich wohl machen müssen Schade eigentlich bin gerade gut dabei ;-)
Zitieren
#10
was du noch machen kannst, ist dass du das teil an den PC anschliesst und testest ob es da geht.
Raspberry Pi 2 , Pollin 7" Display, PIco USV, Jessie Image
Am Testen Raspberry Pi 3, 7" Orginal Display, Jessie Image
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt