Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Navit bleibt still
#1
Ich habe Punkt 5 von http://engineering-diy.blogspot.de/2015/...orial.html gelesen.
Verstehe ich das richtig, dass /home/pi/.navit/speech.sh so ausschauen sollte:

Code:
#!/bin/bash/
echo '$1' > /home/pi/out
f4 - female voice 4
-s speed
-g delay between words
aplay -r 44100 /home/pi/.navit/notification3.wav & sleep 0.7 && espeak -ven+f4 -s150 -a 150 -p 50 "$1" --stdout | aplay
Bei mir bleibt Navit einfach still.
Zum Test habe ich mal

Code:
aplay XXX.mp3
probiert. Auch da höre ich nichts.

Ansonsten funktioniert die Soundausgabe über die USB Soundkarte in Kodi super.
Habe ich etwas übersehen?
Zitieren
#2
Leider hab ich immer noch keinen Erfolg.
Mal eine Frage vorweg. Wenn man in Navit eine Route zum navigieren eingibt, ab wann gibt Navit das erste mal einen Ton oder eine Anweisung aus? Fängt Navit sofort an zu plaudern, auch wenn das Auto still steht oder erst wenn es sich anfängt zu bewegen?
Ich kann es momentan leider mangels defektem Display nur auf dem Tisch zu hause testen.

Ich habe meine USB Soundkarte als erstes Device definiert:

Code:
pi@CarPi ~ $ aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: Device [Generic USB Audio Device], Gerät 0: USB Audio [USB Audio]
 Sub-Geräte: 1/1
 Sub-Gerät #0: subdevice #0
Karte 1: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
 Sub-Geräte: 8/8
 Sub-Gerät #0: subdevice #0
 Sub-Gerät #1: subdevice #1
 Sub-Gerät #2: subdevice #2
 Sub-Gerät #3: subdevice #3
 Sub-Gerät #4: subdevice #4
 Sub-Gerät #5: subdevice #5
 Sub-Gerät #6: subdevice #6
 Sub-Gerät #7: subdevice #7
Karte 1: ALSA [bcm2835 ALSA], Gerät 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
 Sub-Geräte: 1/1
 Sub-Gerät #0: subdevice #0
Im Terminal höre ich so nichts:

Code:
aplay -r 44100 /home/pi/.navit/notification3.wav
So kann ich die wav Datei hören:

Code:
aplay -D plughw:0,0 -r 44100 /home/pi/.navit/notification3.wav

Hat irgendwer bitte eine Idee?
Zitieren
#3
Ein kleines Stück weiter bin ich gekommen. Mit

Code:
aplay -D plughw:0,0 -r 44100 /home/pi/.navit/notification3.wav && sleep 0.7 & espeak -ven+f4 -s150 -a 150 -p 50 "$1" --stdout | aplay
wird jetzt vor jeder "scheinbaren Anweisung" die notificaton3.wav abgespielt. "Scheinbare Anweisung" deshalb, weil ich die Anweisungen immer noch nicht hören kann.

Code:
$ espeak "Hello World"
Hier höre ich nichts. Alerdings kommt auch keine Fehlermeldung. espeak tut so als ob etwas abgespielt wird. Nach beenden lande ich wieder am Prompt.



Code:
$ sudo espeak "Hello World"
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.modem
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.phoneline
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Access denied

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
Trotz der Fehlermeldungen kann ich "Hello World" hören.
Ist das ein Rechteproblem?
Muss der User pi in einer bestimmten Gruppe sein?
Mein User pi gehört der Gruppe audio an.
Oder ist es ein Problem der Lautstärke? Ich meine dass sie Lautstärke beim User pi auf null steht, beim root aber normal laut ist?
Zitieren
#4
Nun höre ich endlich die Anweisungen von Navit. In /etc/pulse/default.pa habe ich folgendes eingetragen bzw. die Kommentierung entfernt:

Code:
load-module module-alsa-sink device=hw:0
load-module module-alsa-source device=hw:0
Zitieren
#5
kannst du mir das mal genauer erleutern ich bekomm das einfach nciht hin

Car pi
Raspberry pi3 Offizielles 7 Zoll Touchscreen

Smart Mirror
Zitieren
#6
Moin,
mein navit spricht jetzt auch mit mir. Allerdings hats recht lange gedauert, die USB-Soundkarte als Karte 0 hinzubekommen. Alle Versuche aplay dazu zu bewegen auf Karte 1 zu dudeln gingen senkrecht in die Hose.

Unter anderem habe ich dabei gelernt, dass das Abschalten des Device Tree in Jessie besser nicht getan werden sollte, der Bildschirm zeigt dann beim Start nur noch seine bunte Farbpalette und nix weiter passierte. Erst das Zupfen der SD-Karte und ändern der config.txt auf den üblichen Standard hat wieder einen sauberen Bootvorgang ermöglicht.

Ich habe letztendlich:
  • in der /boot/config.txt
    Code:
    #dtparam=audio=on
  • auskommentiert
  • in /etc/modprobe.d die Datei alsa-base.conf angelegt und den Parameter 
    Code:
    options snd-usb-audio index=0
  • gesetzt, nur das Deaktivieren des Onboard-Audios hat die USB-Karte trotzdem auf "1" gestellt, weiss der Geier, warum
  • Pi neu gestartet, USB-Karte steht auf "0" - Bingo
  • in der /boot/config.txt
    Code:
    dtparam=audio=on
  • wieder aktiviert
  • Pi neu gestartet, siehe da:
    Code:
    aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: Device [USB Audio Device], Gerät 0: USB Audio [USB Audio]
     Sub-Geräte: 0/1
     Sub-Gerät #0: subdevice #0
    Karte 0: Device [USB Audio Device], Gerät 1: USB Audio [USB Audio #1]
     Sub-Geräte: 1/1
     Sub-Gerät #0: subdevice #0
    Karte 1: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
     Sub-Geräte: 8/8
     Sub-Gerät #0: subdevice #0
     Sub-Gerät #1: subdevice #1
     Sub-Gerät #2: subdevice #2
     Sub-Gerät #3: subdevice #3
     Sub-Gerät #4: subdevice #4
     Sub-Gerät #5: subdevice #5
     Sub-Gerät #6: subdevice #6
     Sub-Gerät #7: subdevice #7
    Karte 1: ALSA [bcm2835 ALSA], Gerät 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
     Sub-Geräte: 1/1
     Sub-Gerät #0: subdevice #0


Damit ist bei mir der Grundstein für erfolgreiches Babbeln über espeak/aplay gelegt worden.

Vllt. hilft das ja, Gruß Wiki
Zitieren
#7
  • options snd-usb-audio index=0
wenn ich den Code in die alsa-base.conf schreibe, ist die USB Soundkarte nicht mehr auswählbar unter
Einstellungen > System >Audio output 
Auch unter aplay -l  wird die USB Card nicht mehr aufgeführt

Ansonsten läuft die Karte für Audio von Kodi - NUR espeak ist weiterhin auf der Klinkenbuchse des Raspi. 
Daher keine Sprachausgabe für Navit :-)

Ich bekomme es nicht hin!
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#8
Ich hänge mich mal dran an diesen Thread.
Mein Navit spricht ebenfalls nicht mit mir.
Aber im Gegensatz zu meinen Vorrednern nutze ich den Klinkenausgang des Raspberry und keine USB-Soundkarte.
Installiert wurde alles gemäß Tutorial von Chr.Brauweiler.

Wo soll ich suchen?
Und wann fängt Navit eigentlich an zu reden? Direkt nach Eingabe der Zieldaten, wenn die Karte angezeigt wird?
Zitieren
#9
Wann Navit anfängt zu reden, wüsste ich auch gerne. Scheinbar erst bei der ersten Richtungsänderung?
Funktioniert denn espeak bei Dir?
Das würde ich mal testen.
Wenn nicht, hast Du den Fehler schon gefunden.
Raspberry Pi 3, 7" RPi Touchscreen, PiUSV+; Jessi, Kodi 15.2
Zitieren
#10
Hiermit testen?

Code:
$ sudo espeak "Hello World"
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt