Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Si4703 -> USB Soundkarte -> kein Ton
#1
Ich habe endlich mein FM Modul bekommen und angeschlossen.
Das Modul ist an Line-In der USB Soundkarte angeschlossen. Leider höre ich keinen Ton.
Wenn ich zum Test Kopfhörer anschließe, funktioniert alles wunderbar.
Die Antenne habe ich wie hier angeschlossen.

Gibt es eine Möglichkeit dem FM Addon mitzuteilen welche Soundkarte benutzt werden soll?
Zitieren
#2
Hat keiner Idee oder Si4703 über LineIn in eine USB Soundkarte erfolgreich laufen? Was habt ihr wo eingestellt?
Ich habe auch Christians Step-by-Step versucht, doch da funktioniert es nicht. Si4703 und USB Soundkarte habe ich beide getestet, beide funktionieren.
Zitieren
#3
Da ich immer noch keinen Erfolg habe, habe ich hier mal gelesen.
Selbst den Test:

Zitat:Simple test.
To understand how this radio server-client works you can make the folowing experiment:
1. Plug the gpio expansion board(or wire the radio module to the PI as in the above schematic)
2. [Server] Connect using one ssh window(I use Putty) to the PI and enter the folowing commands:
cd radio
sudo python radio_server.py
The radio server should initialize the  radio module and start the server.
3. [Client] go to the radio folder and use radio_client.py to send commands o the radio server, like in the folowing picture:
kann ich nicht durchführen, da es kein Verzeichnis "radio" in /home/pi gibt.

Nochmal die Frage: hat denn niemand das Si4703 an einer USB Soundkarte angeschlossen. Ich bräuchte wirklich paar hilfreiche Gedanken bzw. Tips. Ist doch Mist, wenn (fast) alles funktioniert nur das Radiomodul nicht.
Zitieren
#4
Eigentlich gibt es da nicht viel zu beachten, auch nichts mit Radio Server usw. Einfach dranstecken und in Raspbian natürlich unter den Soundeinstellungen auch das Micro / den Line In aktivieren bzw. dessen Lautstärke erhöhen. Sieht nicht genauso wie auf dem Bild aus, aber dort musst du unten links auf "select Controls" dann kannst du anhaken, dass du auch den Line In und das Micro einstellen möchtest. Dann hast du Schieberegler dafür und kannst diese erhöhen. Ich benutze es mit dieser Soundkarte. Mir macht eher die Antenne probleme Big Grin
Zitieren
#5
Danke chef1702 für deine Antwort. Genauso eine USB Soundkarte habe ich auch.
Die Schieberegler habe ich alle schon durch, alle stehen auf 100%. Big Grin 
Ich habe eben mal folgendes probiert:
Ich habe Kodi beendet und in Raspbian im Terminal folgendes eingegeben:
Code:
arecord -D plughw:0,0 -c 2 -fS16_LE -r 44100 | aplay -D plughw:0,0 -
Damit habe ich die USB Soundkarte direkt zur Aufnahme und Wiedergabe angesprochen.
Zum Test habe ich das Handy an den Mikrofonanschluss angeschlossen. Das funktioniert so wunderbar. Also war der nächste Test dann den Si4703 so anzuschließen. Und siehe da, ich bekam das Radiorauschen zu hören was ich erwartet habe. Einen Sender kann ich ja leider so nicht einstellen.
Also hakt es doch irgendwie an den Soundeinstellungen....nur wo?
Im Log von Kodi habe ich noch das hier gefunden:

Code:
DEBUG: CPythonInvoker(9, /home/pi/.kodi/addons/plugin.program.radioFM/addon.py): instantiating addon using automatically obtained id of plugin.program.radioFM dependent on version 2.1.0 of the xbmc.python api
Damit kann ich leider nichts anfangen.
Zitieren
#6
HAi,
komme zwar zwei Jahre zu spät aber vielleicht hat ein anderer die selben Probleme und kann das hier lesen.

Hast Du den alsamixer schon mal aufgerufen?
Dort nehme ich immer meine Einstellungen vor.
https://askubuntu.com/questions/50067/ho...r-settings

Bye
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt