Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
HifiBerry DAC+ und SI4703 radio modul
#31
Das lese ich aber nicht gerne, dass es noch dauert mit dem neuem Controller Sad
Zitieren
#32
Kommt halt alles erst wenn Andrei den letzten "Bug" ausgetrieben hat.
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#33
Verständlich.
Kommt Hawkeye dann auch wieder? Ganz schön ruhig um ihn geworden...
Zitieren
#34
Der hat im Moment viel um die Ohren. Neuer Job und so...
CarPi: RPi 3 mit 7" RPi Touchscreen & PiUSV+, Jessie, Kodi 15.2
Testing: Raspbian Jessie mit Kodi 15.2 - Step by Step
Projekte: SmartHome, Ambilight
Zitieren
#35
(26.01.2017, 16:03)eRRoXxX schrieb: Habe das thema  Si4703 Anschluss mitgelesen und die anleitung die roughtrade das gelinkt hat befolgt.

Code:
root@CarPi:~/RdSpi# sudo i2cdetect -y 1
    0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          03 04 05 06 07 08 09 0a 0b 0c 0d 0e 0f
10: 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f
20: 20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f
30: 30 31 32 33 34 35 36 37 38 39 3a 3b 3c 3d 3e 3f
40: 40 41 42 43 44 45 46 47 48 49 4a 4b 4c UU 4e 4f
50: 50 51 52 53 54 55 56 57 58 59 5a 5b 5c 5d 5e 5f
60: 60 61 62 63 64 65 66 67 68 69 6a 6b 6c 6d 6e 6f
70: 70 71 72 73 74 75 76 77
root@CarPi:~/RdSpi# sudo ./rdspi reset
Reset Map:
0 0000
1 0000: REV 0 DEV Si4702 FIRMWARE 0
2 0000: DSMUTE 0 DMUTE 0 MONO 0 RDSM 0 SKMODE 0 SEEKUP 0 SEEK 0 DISABLE 0 ENABLE                                                                                                              0
3 0000: TUNE 0 CHAN 0 (87.50MHz)
4 0000: RDSIEN 0 STCIEN 0 RDS 0 DE 0 AGCD 0 BLNDADJ 0 GPIO3 0 GPIO2 0 GPIO 0
5 0000: SEEKTH 0 BAND 0 SPACE 0 VOLUME 0
6 0000: SMUTER 0 SMUTEA 0 RDSPRF 0 VOLEXT 0 SKSNR 0 SKCNT 0
7 0000: XOSCEN 0 AHIZEN 0
8 0000
9 7EAF
A 0000: RDSR 0 STC 0 SF/BL 0 AFCRL 0 RDSS 0 BLERA 0 ST 0 RSSI 0
B 0000: BLERB 0 BLERC 0 BLERD 0 READCHAN 0 (87.50MHz)
C 0000
D 0000
E 0000
F 0000

Oscillator enabled:
0 0000
1 0000: REV 0 DEV Si4702 FIRMWARE 0
2 0000: DSMUTE 0 DMUTE 0 MONO 0 RDSM 0 SKMODE 0 SEEKUP 0 SEEK 0 DISABLE 0 ENABLE                                                                                                              0
3 0000: TUNE 0 CHAN 0 (87.50MHz)
4 0000: RDSIEN 0 STCIEN 0 RDS 0 DE 0 AGCD 0 BLNDADJ 0 GPIO3 0 GPIO2 0 GPIO 0
5 0000: SEEKTH 0 BAND 0 SPACE 0 VOLUME 0
6 0000: SMUTER 0 SMUTEA 0 RDSPRF 0 VOLEXT 0 SKSNR 0 SKCNT 0
7 0000: XOSCEN 0 AHIZEN 0
8 0000
9 7EAF
A 0000: RDSR 0 STC 0 SF/BL 0 AFCRL 0 RDSS 0 BLERA 0 ST 0 RSSI 0
B 0000: BLERB 0 BLERC 0 BLERD 0 READCHAN 0 (87.50MHz)
C 0000
D 0000
E 0000
F 0000

Powerup:
0 0000
1 0000: REV 0 DEV Si4702 FIRMWARE 0
2 0001: DSMUTE 0 DMUTE 0 MONO 0 RDSM 0 SKMODE 0 SEEKUP 0 SEEK 0 DISABLE 0 ENABLE                                                                                                              1
3 0000: TUNE 0 CHAN 0 (87.50MHz)
4 1800: RDSIEN 0 STCIEN 0 RDS 1 DE 1 AGCD 0 BLNDADJ 0 GPIO3 0 GPIO2 0 GPIO 0
5 0C10: SEEKTH 12 BAND 0 SPACE 1 VOLUME 0
6 024F: SMUTER 0 SMUTEA 0 RDSPRF 1 VOLEXT 0 SKSNR 4 SKCNT 15
7 0000: XOSCEN 0 AHIZEN 0
8 0000
9 0000
A 0000: RDSR 0 STC 0 SF/BL 0 AFCRL 0 RDSS 0 BLERA 0 ST 0 RSSI 0
B 0000: BLERB 0 BLERC 0 BLERD 0 READCHAN 0 (87.50MHz)
C 0000
D 0000
E 0000
F 0000

Tuned
0 0000
1 0000: REV 0 DEV Si4702 FIRMWARE 0
2 0000: DSMUTE 0 DMUTE 0 MONO 0 RDSM 0 SKMODE 0 SEEKUP 0 SEEK 0 DISABLE 0 ENABLE                                                                                                              0
3 0000: TUNE 0 CHAN 0 (87.50MHz)
4 0000: RDSIEN 0 STCIEN 0 RDS 0 DE 0 AGCD 0 BLNDADJ 0 GPIO3 0 GPIO2 0 GPIO 0
5 0000: SEEKTH 0 BAND 0 SPACE 0 VOLUME 0
6 0000: SMUTER 0 SMUTEA 0 RDSPRF 0 VOLEXT 0 SKSNR 0 SKCNT 0
7 0000: XOSCEN 0 AHIZEN 0
8 0000
9 7EAF
A 0000: RDSR 0 STC 0 SF/BL 0 AFCRL 0 RDSS 0 BLERA 0 ST 0 RSSI 0
B 0000: BLERB 0 BLERC 0 BLERD 0 READCHAN 0 (87.50MHz)
C 0000
D 0000
E 0000
F 0000


Und ich kann die freq. nicht wechseln.
Code:
root@CarPi:~/RdSpi# sudo ./rdspi tune 95.00
Tuned to 87.50MHz
Register map:
0 0000
1 0000: REV 0 DEV Si4702 FIRMWARE 0
2 0000: DSMUTE 0 DMUTE 0 MONO 0 RDSM 0 SKMODE 0 SEEKUP 0 SEEK 0 DISABLE 0 ENABLE                                                                                                              0
3 0000: TUNE 0 CHAN 0 (87.50MHz)
4 0000: RDSIEN 0 STCIEN 0 RDS 0 DE 0 AGCD 0 BLNDADJ 0 GPIO3 0 GPIO2 0 GPIO 0
5 0000: SEEKTH 0 BAND 0 SPACE 0 VOLUME 0
6 0000: SMUTER 0 SMUTEA 0 RDSPRF 0 VOLEXT 0 SKSNR 0 SKCNT 0
7 0000: XOSCEN 0 AHIZEN 0
8 0000
9 0000
A 0000: RDSR 0 STC 0 SF/BL 0 AFCRL 0 RDSS 0 BLERA 0 ST 0 RSSI 0
B 0000: BLERB 0 BLERC 0 BLERD 0 READCHAN 0 (87.50MHz)
C 0000
D 0000
E 0000
F 0000

Also die i2c-init.c sieht bei mir so aus:
PHP-Code:
/* i2c-init.c */
#include <wiringPi.h>

int main() {
 
   int resetPin 4// GPIO23
 
   int sdaPin 2// GPIO0

 
   /* Setup GPIO access in BCM mode */
 
   wiringPiSetupGpio();

 
   /* Set pins as output */
 
   pinMode(resetPinOUTPUT);
 
   pinMode(sdaPinOUTPUT);
 
    /* A low SDA indicates a 2-wire interface */
 
   digitalWrite(sdaPinLOW);
 
   /* Put chip into reset */
 
   digitalWrite(resetPinLOW);
 
   /* 1ms delay to allow pins to settle */
 
   delay(1);
 
   /* Bring chip out of reset with SDIO set low
    and SEN pulled high (with pull-up resistor) */
 
   digitalWrite(resetPinHIGH);

 
   return 0;



Die verkablung nochmals:
3.3V auf 3.3V ( Header Pin 1)
GND auf GND (header pin 9)
SDIO auf I2C1 SDA (header pin 3)
SCLK auf I2C1 SCL (hader pin 5)
SEN - NC
RST auf GPIO4 ( header pin 7)
GPIO1 - NC
GPIO2 auf GPIO 25(header pin 22)

Jemand eine idee? Bin am verzweifeln

Danke
Sorry das ich ein alteres thema aufwirbel, aber eventuell hilft es leuten später da auch ich auf diese thema per google gestößen bin, habe mich extra dafür angemeldet, ich hatte es auch das mir das modul als si4702 Firmware 0 angezeigt wurde, habe stundenlang versucht es zu lösen, nach einem eingehendem blick auf das modul selbst habe ich gesehen das dieses längliche silberne ding auf dem modul nur an einer seite kontakt am lötpunkt hatte, als ich diesen wieder angelötet habe ist das modul sofort in betrieb gesprungen und wurde als si4703 firmware 19 erkannt, hoffe das hilft jemandem weiter.

[Bild: dffed7-1524939493.jpg]
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
RasPiCarProjekt